Resource icon

MyHero Levels 1.02

Compatible API Versions
1.0.5
Simple library for player levels.

Need MyHero Core 1.2 or newer and DbLib

Required for exp drop in MyHero Mobs.

Examples of use:
MyHeroLevel mhl = MyHeroMain_Levels.getAPI().getMyHeroLevel(player);
mhl.addExp(100);

Bugs report here: https://github.com/EnterTG/MyHero_Items_Nukkit/issues
Author
WindSkull
Downloads
639
Views
639
First release
Last update
Rating
1.00 star(s) 1 ratings

Latest updates

  1. Update to 1.02 version

    Require MyHero Core 1.23
  2. Update for #423

    Update for mc 1.11
  3. MyHero Levels 1.1

    Some fixs

Latest reviews

14:42:42 [INFO ] Enabling MyHeroLevels v1.01
14:42:42 [ERROR] Throwing
java.lang.RuntimeException: java.lang.NullPointerException
at cn.nukkit.plugin.PluginManager.enablePlugin(PluginManager.java:443) ~[nukkit-1.0-SNAPSHOT.jar:?]
at cn.nukkit.Server.enablePlugin(Server.java:741) ~[nukkit-1.0-SNAPSHOT.jar:?]
at cn.nukkit.Server.enablePlugins(Server.java:730) ~[nukkit-1.0-SNAPSHOT.jar:?]
at cn.nukkit.Server.<init>(Server.java:566) ~[nukkit-1.0-SNAPSHOT.jar:?]
at cn.nukkit.Nukkit.main(Nukkit.java:112) ~[nukkit-1.0-SNAPSHOT.jar:?]
Caused by: java.lang.NullPointerException
at MyHero_Levels.Core.DataManager.InicializeAPI(DataManager.java:28)
~[?:?]
at MyHero_Levels.Core.MyHeroMain_Levels.onEnable(MyHeroMain_Levels.java:22) ~[?:?]
at cn.nukkit.plugin.PluginBase.setEnabled(PluginBase.java:89) ~[nukkit-1.0-SNAPSHOT.jar:?]
at cn.nukkit.plugin.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:117) ~[nukkit-1.0-SNAPSHOT.jar:?]
at cn.nukkit.plugin.PluginManager.enablePlugin(PluginManager.java:439) ~[nukkit-1.0-SNAPSHOT.jar:?]
Top