Plugins on a MCPE server don't work

Atten007

New Member
Hi folks,

I set up a nukkit minecraft server for my school on my private raspberry pi 4B with 4GB of RAM and now my friends from my school want to play on the server with plugins. I've installed 6 plugins on the server (they're stored in the right folder, the folder's name is "plugins"). But when I start the server and tjoin, I issue the server command "/pl" and it shows me "Plugins (0):". Have I made something wrong? An answer would be really nice.

The server log:

[email protected]:~ $ java -jar /home/pi/brückenschule-mcpe/nukkit.jar
18:28:02 [INFO ] Loading nukkit.yml ...
18:28:02 [INFO ] Loading server.properties ...
18:28:03 [ERROR] Throwing
java.io.FileNotFoundException: /home/pi/server.properties (Keine Berechtigung)
at java.io.FileOutputStream.open0(Native Method) ~[?:1.8.0_251]
at java.io.FileOutputStream.open(FileOutputStream.java:270) ~[?:1.8.0_251]
at java.io.FileOutputStream.<init>(FileOutputStream.java:213) ~[?:1.8.0_251]
at java.io.FileOutputStream.<init>(FileOutputStream.java:162) ~[?:1.8.0_251]
at cn.nukkit.utils.Utils.writeFile(Utils.java:38) ~[nukkit.jar:?]
at cn.nukkit.utils.Utils.writeFile(Utils.java:28) ~[nukkit.jar:?]
at cn.nukkit.utils.Config.save(Config.java:244) [nukkit.jar:?]
at cn.nukkit.utils.Config.save(Config.java:212) [nukkit.jar:?]
at cn.nukkit.utils.Config.load(Config.java:162) [nukkit.jar:?]
at cn.nukkit.utils.Config.<init>(Config.java:98) [nukkit.jar:?]
at cn.nukkit.Server.<init>(Server.java:349) [nukkit.jar:?]
at cn.nukkit.Nukkit.main(Nukkit.java:120) [nukkit.jar:?]
18:28:03 [INFO ] Deutsch (deu) als Standard eingestellt
18:28:03 [INFO ] Starte Minecraft: BE mit Version v1.16.220
18:28:03 [INFO ] Selected Zlib Provider: 2 (cn.nukkit.utils.ZlibThreadLocal)
18:28:03 [INFO ] Starte Server auf 0.0.0.0:19132
18:28:03 [INFO ] Dieser Server startet mit der Version Nukkit git-5e95fe7 "" (API: 1.0.12)
18:28:03 [INFO ] Nukkit wird unter der LGPL-Lizenz vertrieben
18:28:03 [WARN ] Failed to create bStats metrics directory
18:28:06 [INFO ] Loading recipes...
18:28:07 [INFO ] Loaded 1509 recipes.
18:28:07 [INFO ] Successfully loaded 0 resource packs
18:28:08 [INFO ] Vorbereiten der Welt "world"
18:28:08 [INFO ] Preparing start region for level "world"
18:28:08 [INFO ] Vorbereiten der Welt "nether"
18:28:08 [INFO ] Preparing start region for level "nether"
18:28:08 [INFO ] Starte GS4 Status-Listener
18:28:08 [INFO ] Setze Query-Port auf 19132
18:28:08 [INFO ] Query startet auf 0.0.0.0:19132
18:28:08 [INFO ] Standard-Spielmodus: Kreativmodus
18:28:08 [INFO ] Fertig! (5.997s)! F\u00fcr Hilfe, tippe "help" oder "?"
18:28:08 [ERROR] Throwing
java.io.FileNotFoundException: /home/pi/server.properties (Keine Berechtigung)
at java.io.FileOutputStream.open0(Native Method) ~[?:1.8.0_251]
at java.io.FileOutputStream.open(FileOutputStream.java:270) ~[?:1.8.0_251]
at java.io.FileOutputStream.<init>(FileOutputStream.java:213) ~[?:1.8.0_251]
at java.io.FileOutputStream.<init>(FileOutputStream.java:162) ~[?:1.8.0_251]
at cn.nukkit.utils.Utils.writeFile(Utils.java:38) ~[nukkit.jar:?]
at cn.nukkit.scheduler.FileWriteTask.onRun(FileWriteTask.java:51) [nukkit.jar:?]
at cn.nukkit.scheduler.AsyncTask.run(AsyncTask.java:23) [nukkit.jar:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_251]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_251]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_251]
> pl
18:28:14 [INFO ] Plugins (0):


Sincerely yours,
Atten007
 

Sleepybear

Moderator
Staff member
sudo chmod +rw server.properties

But that could also be the problem for the plugins, is that the file permissions are incorrect.
Please do cd plugins and then do ls -la and let us see the results.
 

Atten007

New Member
sudo chmod +rw server.properties

But that could also be the problem for the plugins, is that the file permissions are incorrect.
Please do cd plugins and then do ls -la and let us see the results.
I tried the both attempts above, but they didn't work! =(
 

Atten007

New Member
Hi folks,

I have another error in my mcpe server (java.util.concurrent.CompletionException java.net.BindException: The adress is already in use. Here's the link to the latest server log:


Has anyone an idea how I can fix this error? Because I need plugins and they don't work with the error.

Sincerely yours,
Atten007 =)
 
Top