Plan | Player Analytics

Plan | Player Analytics 5.6 build 2614

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Change log 5.5 build 2121

5.5 build 2121
Another release to add 1.19.3 support to Fabric and release all the goodies developed since previous update :)
Special thanks to DrexHD for contributions to this update.
Change Log
Data gathering
Read the rest of this update entry...
 

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Change log 5.5 build 2144

5.5 build 2144
This build contains various bugfixes.
Change log
Join Address Data
  • Any join address data that has null characters (gathering was fixed in previous update) is now cleaned on first startup - the data after null character is cleared, and the valid data kept. This should help with join address tab not loading in many cases. This was thoroughly unit tested to ensure it works properly.
...
Read the rest of this update entry...
 

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Hotfix - Change log 5.5 build 2150

5.5 build 2150 - Hotfix
This update contains a hotfix to build 2144. New installations after build 2100 are not affected - The bug affected instances that were updated from versions prior to build 2100 on networks or fabric servers. Sorry for any inconvenience it has caused. More about the bug below.
Fixed bug in BadJoinAddressCorrectionPatch
An unfortunate typo in session to join address id correction code caused all sessions to get invalid join...
Read the rest of this update entry...
 

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Change log 5.5 build 2163

5.5 build 2163
This update contains performance improvements and subdirectory support for the new frontend.
Change log
Database
  • Fixed concurrency bottleneck where write and read operations interfered with each other, limiting to one query or transaction from executing at the same time. This bottleneck occurred since the access-lock designed to prevent database operations during schema modifications was still...
Read the rest of this update entry...
 

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

5.5 build 2172 - CRITICAL security vulnerability fix

5.5 build 2172 - CRITICAL security vulnerability fix
This build contains a fix to a CRITICAL SQL Injection vulnerability, as well as fixes to minor security vulnerabilities.
Yesterday (2023-01-14): Finding a minor Path Traversal security vulnerability lead to a throughout process of labeling all untrusted data in the codebase, and during that process a critical SQL Injection vulnerability was also discovered. When exploited successfully SQL Injection allows a...
Read the rest of this update entry...
 

PlajerCS

Member
@AuroraLS3 Hi i have this error code:


Code:
java.lang.UnsupportedClassVersionError: com/djrapitops/plan/PlanNukkit has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_312]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:756) ~[?:1.8.0_312]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_312]
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:473) ~[?:1.8.0_312]
        at java.net.URLClassLoader.access$100(URLClassLoader.java:74) ~[?:1.8.0_312]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:369) ~[?:1.8.0_312]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:363) ~[?:1.8.0_312]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_312]
        at java.net.URLClassLoader.findClass(URLClassLoader.java:362) ~[?:1.8.0_312]
        at cn.nukkit.plugin.PluginClassLoader.findClass(PluginClassLoader.java:44) ~[server.jar:?]
        at cn.nukkit.plugin.JavaPluginLoader.getClassByName(JavaPluginLoader.java:145) ~[server.jar:?]
        at cn.nukkit.plugin.PluginClassLoader.findClass(PluginClassLoader.java:40) ~[server.jar:?]
        at cn.nukkit.plugin.PluginClassLoader.findClass(PluginClassLoader.java:28) ~[server.jar:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_312]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_312]
        at cn.nukkit.plugin.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:47) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugin(PluginManager.java:95) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:285) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:132) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:124) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:120) ~[server.jar:?]
        at cn.nukkit.Server.<init>(Server.java:505) ~[server.jar:?]
        at cn.nukkit.Nukkit.main(Nukkit.java:120) [server.jar:?]
 

AuroraLS3

Member
@AuroraLS3 Hi i have this error code:


Code:
java.lang.UnsupportedClassVersionError: com/djrapitops/plan/PlanNukkit has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_312]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:756) ~[?:1.8.0_312]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_312]
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:473) ~[?:1.8.0_312]
        at java.net.URLClassLoader.access$100(URLClassLoader.java:74) ~[?:1.8.0_312]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:369) ~[?:1.8.0_312]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:363) ~[?:1.8.0_312]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_312]
        at java.net.URLClassLoader.findClass(URLClassLoader.java:362) ~[?:1.8.0_312]
        at cn.nukkit.plugin.PluginClassLoader.findClass(PluginClassLoader.java:44) ~[server.jar:?]
        at cn.nukkit.plugin.JavaPluginLoader.getClassByName(JavaPluginLoader.java:145) ~[server.jar:?]
        at cn.nukkit.plugin.PluginClassLoader.findClass(PluginClassLoader.java:40) ~[server.jar:?]
        at cn.nukkit.plugin.PluginClassLoader.findClass(PluginClassLoader.java:28) ~[server.jar:?]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_312]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_312]
        at cn.nukkit.plugin.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:47) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugin(PluginManager.java:95) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:285) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:132) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:124) ~[server.jar:?]
        at cn.nukkit.plugin.PluginManager.loadPlugins(PluginManager.java:120) ~[server.jar:?]
        at cn.nukkit.Server.<init>(Server.java:505) ~[server.jar:?]
        at cn.nukkit.Nukkit.main(Nukkit.java:120) [server.jar:?]
Plan requires Java 11 or newer
 

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Change log 5.5 build 2272

5.5 build 2272
This update enables the new React based frontend by default, speeds up loading various parts of the website, and fixes a couple of issues.
If you are using Html Customization, it is now possible to migrate to the new system, see https://github.com/plan-player-analytics/Plan/wiki/Html-Customization--migration-guide-to-React - You can use Plugin.Use_Legacy_Frontend setting until your migrations are complete.
Back up your config in case you...
Read the rest of this update entry...
 

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Change log 5.5 build 2391

Change Log 5.5 build 2391

This is a feature packed update, as it brings support for multiple proxy servers, IP allowlist CIDR and Dynamic DNS support, Fabric 1.19.4, and lots and lots of improvements.

Special thanks to Kopo, WolverStones & inductor for contributions to this update!

Change log
Fabric 1.19.4
  • Kopo updated Fabric support to 1.19.4, older versions are no longer be supported by this version
  • Kopo fixed Gamemode change...
Read the rest of this update entry...
 

AuroraLS3

Member

AuroraLS3

Member
AuroraLS3 updated Plan | Player Analytics with a new update entry:

Web User Access-Control - Change log 5.6 build 2614

Web User Access-Control - Change log 5.6 build 2614

Hello! This version contains a hefty set of new features, bugfixes and usability improvements. Highlighted features include Web User Access-Control, Plugin Version History and 'Click to see Who'-features. There are a lot more new things so check out the change log.

Updating to this version modifies database schema
There is a guide for updating to this version here...
Read the rest of this update entry...
 

nixybuilder

Member
How do i acess website when i cant use localhost? I have hosting not local server, it doesnt work with my server ip and the port i tried everything but i cant acess the website...
 
Top